• Opening Meter Reading (Pure Planet App Photo Image)

    Would you be kind enough to send me my Opening (Electric/Gas) Meter Readings photo image as taken using the Pure Planet App on or around April 1st, 2019 (Joining date)

    In summary, both my British Gas (Closing) and Pure Planet (Opening) Electricity Meter Readings are the same value (11161). However having sent my reading for the Month of April (14700) the usage is excessively and unusually high and therefore I am trying to identify what could have possibly done wrong ?

    I have spoken to BG who tell me that their closing balance is correct and my monthly usage for the 5 year period of being a BG customer was approximately 350 units and here we see the PP usage to be 10 times that value ?

    I would like to add that we were away for 7 days during the Easter Holidays in April and am therefore very confused on where this discrepancy lies.

    Many thanks


    ​Brian
    Tap below to see the best answer
    0
  • Would you be kind enough to send me my Opening (Electric/Gas) Meter Readings photo image as taken using the Pure Planet App on or around April 1st, 2019 (Joining date)

    In summary, both my British Gas (Closing) and Pure Planet (Opening) Electricity Meter Readings are the same value (11161). However having sent my reading for the Month of April (14700) the usage is excessively and unusually high and therefore I am trying to identify what could have possibly done wrong ?

    I have spoken to BG who tell me that their closing balance is correct and my monthly usage for the 5 year period of being a BG customer was approximately 350 units and here we see the PP usage to be 10 times that value ?

    I would like to add that we were away for 7 days during the Easter Holidays in April and am therefore very confused on where this discrepancy lies.

    Many thanks


    ​Brian
    Tap below to see the best answer


  • Best Answer

    Hey @Buck Rogers

    Just to let you know this is a public forum and isn't a message to our Member Services team - if you tap 'help' > 'Ask WattBot' in your app you can send this request to the team.

    Sounds like something's gone wrong with your usage - if you send a photo of your current meter reading in your WattBot chat the team will be able to check that it and your opening reading are correct. If not, they'll let you know the next steps to get them corrected and how to investigate if your meter is giving faulty readings.
    0
  • Hey @Buck Rogers

    Just to let you know this is a public forum and isn't a message to our Member Services team - if you tap 'help' > 'Ask WattBot' in your app you can send this request to the team.

    Sounds like something's gone wrong with your usage - if you send a photo of your current meter reading in your WattBot chat the team will be able to check that it and your opening reading are correct. If not, they'll let you know the next steps to get them corrected and how to investigate if your meter is giving faulty readings.