Solved

ihd "waiting for data" code 28-1

  • 27 October 2020
  • 23 replies
  • 252 views

Ihd still “waiting for data” and showing system code 28-1. It’s been like this since installation in early October. Any ideas on how to fix?

icon

Best answer by Angelabikerbabe 27 October 2020, 11:48

Hi
here's a link for you to have a look at.:https://community.purepla.net/smart-meters-and-ihds-33/ihd-isn-t-working-10331

 

If your IHD isn't working as it should, in your account go to ‘get help and support’ > ‘ask a question’, and type the words 'IHD problem'. WattBot will take a bit more info from you and then pass this on to our Member Services team to investigate.

View original

23 replies

Userlevel 7
Badge +9

Hi
here's a link for you to have a look at.:https://community.purepla.net/smart-meters-and-ihds-33/ihd-isn-t-working-10331

 

If your IHD isn't working as it should, in your account go to ‘get help and support’ > ‘ask a question’, and type the words 'IHD problem'. WattBot will take a bit more info from you and then pass this on to our Member Services team to investigate.

Thanks. Went down that route a couple of weeks ago but didn’t get any response. The ihd is connected to the network by the way with a strong signal indicated (its within a metre of the meter).

Hey @RobertW 

I flagged this with our Member Services team - they let me know they were waiting on some work being done by a third party, to allow them to run some updates on the IHD which they’ve now been able to do - Sam from the team has emailed you about this now :relaxed:

All sorted wef 4th Nov. Meter now connecting with ihd and displaying data as it should. Many thanks to the Member Services team for fixing this problem.

I have the same problem since installation yesterday.

I cannot ask WattBot as it just says “Problem sending message Please try again”

Can you help please @Nataly 

Userlevel 7
Badge +8

I have the same problem since installation yesterday.

I cannot ask WattBot as it just says “Problem sending message Please try again”

Can you help please @Nataly 

@coombs.r.p 

If your meter was only fitted yesterday, I would wait a while before contacting the team. It can sometimes take days before the IHD connects.

All you can do for the moment is place the IHD as close as possible to the electric meter and hope for the best

Hi @coombs.r.p 

Thanks for posting and welcome to the Community!

Spot on advice here from @Duppy, thank you for the speedy and helpful response @Duppy!

We recommend you wait a week or so before contacting the team as it can take a little while to all connect up - this may also be useful:

I hope this helps!

Great, thanks both!

(May be worth noting this in the instructions in case others have the same problem)

Good shout @coombs.r.p! I’ve added that in now :blush:

Er, but watt about the broken bot?

Er, but watt about the broken bot?


Yes that’s strange… I’ve tried on Firefox and Chrome. In the chat with WattBot, I can see his first introduction message. But when I type anything and hit send, I get a red bar at the bottom of the page saying “Problem sending message Please try again”. No idea why!

See this experience whilst playing IHD... 

 

Fair point @coombs.r.p! I created a bug report over here so it doesn’t get overlooked:

 

Userlevel 7
Badge +9

Oh dear

Fair point @coombs.r.p! I created a bug report over here so it doesn’t get overlooked:

 

No need @25 quid We can pick it up here. Otherwise we’ll have duplicate conversations taking place :thumbsup:

I sensed Nats was closing the topic down here… 😉 

Dib dib dib, just being safe. 😊 


Yes that’s strange… I’ve tried on Firefox and Chrome. In the chat with WattBot, I can see his first introduction message. But when I type anything and hit send, I get a red bar at the bottom of the page saying “Problem sending message Please try again”. No idea why!

Hello @coombs.r.p 

Hmm. That’s odd. It sounds like you may be running a VPN? Or some kind of proxy? Poor old Watt isn’t massively keen on those. Any chance you could turn it off?

Thanks @Marc , you’re right, switching off my VPN solved the issue for me.

Just curious @Marc, why is the bot sensitive in that area? Is there a good reason you fancy sharing? 😊 

Thanks @Marc , you’re right, switching off my VPN solved the issue for me.

Fantastic! thanks for letting us know @coombs.r.p :smile:

Why does Wattbot not work with VPNs?

It traps many people at their time of need. Surely it’d be worth making its dialogue look like normal web traffic so the wise words are not curtailed?

Hey @25 quid 

I’ve merged your post into this thread so it’s together with your original question, to avoid posting duplicate replies. :slight_smile:

It’s a good question, and to be honest, although we know it’s a security feature, we wouldn’t be able to tell you the in-depth technical reasons behind it! 

I know I’ve encountered the same thing with other chat bots for other companies, too. 

Maybe someone else on the Community has experience of this or knowledge of the technicalities? 

Sorry not to be able to give you a more in-depth answer on this one. 

I suppose it was a more rhetorical question. I had a hack and see Mr Bott connects to: 

URL: wss://rtmmsg.imiconnect.io:8884/mqtt

So that’s a funny websocket protocol (wss) on a funny port (8884, rather than https on 443).

So this probably means that the VPN doesn’t route these messages and hence Mr. Bot dies.

  1. The geeks could probably detect this lack of communication and show a helpful message
  2. The geeks could choose to route over a normal port, but they’ll probably claim a security benefit by going left-field.

Option 1 could make life more pleasant for punters!

Reply