Question

Unable to contact via WattBot

  • 7 April 2021
  • 5 replies
  • 31 views

Hi there

 

I’ve tried contacting Customer Services via WattBot since 1st April, however I’m constantly getting a “We are experiencing difficulty at the moment please try again” auto-response. 
 

They’ve been investigating an issue in my billing since I switched over to a smart meter since beginning of February. 
 

I’ve tried contacting via a Twitter DM but no reply either. 
 

Do they have a contact number?

 

Thanks


5 replies

Hi @GingerLlama,

Welcome to the community, what a great name! I’ve not seen anyone else mentioning this. Could you try restarting your device please? If that doesn’t fix it perhaps you could tell us what device and version you’re using so PP can investigate. You can also paste a screenshot.

If you get no joy, you can try help@purepla.net, however the Wattbot is usually the quickest way to get help (around 3 days). 

Thanks for the reply. 
 

I’ve uninstalled and reinstalled the app. I’ve got the most recent iOS as well. 
 

I have now sent an email - hopefully this can be resolved. 
 

Cheers

 

Toby
 

 

Userlevel 7
Badge +8

Some alternative ways to contact PP

Hey Toby @GingerLlama 

Fantastic username :slight_smile:  welcome to the Community! 

It’s worth checking you’re not currently using a VPN, or a work phone for example - that can block WattBot from working correctly? 

It may also be worth logging in to your account online at purepla.net, to see if your messages would send there (in case it is a phone issue). :thumbsup:

Userlevel 7
Badge +8

@GingerLlama 

I would point out that after having a new meter fitted, there is usually a disruption of the statements until the new meter details are registered with the database, and the old meter is deregistered. It can but not always take a few months to sort

Reply