How to pay

  • 9 February 2019
  • 4 replies
  • 497 views

I am new to the community site. My husband recently died and he dealt with Pure Planet. I have contacted them to arrange for the bills to be switched to my name. After a few emails and phone calls they took my bank details back in January 2019. I have now received a bill which shows that no payments have been made. Although the bill asks for payment to be made there are no details on how to pay. What do I do next?

4 replies

Userlevel 7
Badge +9
Hello dispicer5.

Firstly sorry for your loss.
You receive a monthly statement from PP. Due to dates and time taken setting up the acct in your name and the DD details it is possible that you could receive a statement without any payment showing. So nothing to worry about yet.

Check on the app in the balance and payments section.on homepage tap on 3 bars top right. This will show the details of your bank acct from which payment is taken and the date payment is made.
Provided it shows a payment plan then all is good and nothing to worry about.
If not post back here for further assistance.
Thank you for your reply. I have had a look at the app as you have suggested but there is nothing set up for balance and payments. Under help I asked WattBot for account details but I don't think anything is set up as I only got the continual spinners in thinking mode. I assume my account is not yet set up. Is there anything I can do to progress this with Pure Planet?
Userlevel 7
Badge +9
dispicer5;23296:
Thank you for your reply. I have had a look at the app as you have suggested but there is nothing set up for balance and payments. Under help I asked WattBot for account details but I don't think anything is set up as I only got the continual spinners in thinking mode. I assume my account is not yet set up. Is there anything I can do to progress this with Pure Planet?


Marc will spot this later and give better advice as to what status your acct is at, dont worry all will be sorted.
Hi @dspicer5
I've flagged this up with our Member services team.
Can you try logging off and then log in again?

Reply