setting up an account



I’ve been trying to set up my account but I get stuck at the ‘select your tariff’ step. When I try to proceed forward, after selecting my usage, by pressing the ‘next’ button nothing happens and I can go on. 


Can you please help with this?



14 replies

Hiya @KGospodinova

I just tried this and I get this button appears after selecting a tariff.

Then it goes to the next page.

What do you see Katerina?



I am trying to complete the ‘move in’  form and I get stuck at this stage. 


When I press the next button nothing happens. 




Odd. Maybe try closing your browser (or the App) and doing it again?

Are you saying that the Next button doesn’t work? Does it change colour? In the past I’ve noticed some PP buttons are a bit slow/stupid/sticky and need a long tap or a hold before they respond. Just a thought…

Let us know how you get on!

PS I don’t think can’t try a move in form myself.

PPS. If you’re using a browser (not the App) how about trying a different one? Swap to Safari, or Chrome, or Firefox, or Opera etc...



It does change colour but nothing happens no mattere how many times I press it or for how long I keep it pressed. 


I’ve tried different browsers and devices, but nothing helps. I am having this problem since Friday. 


Thanks for your help, 


Clutching at straws. Maybe try increasing your energy usage slightly. Those figures are the standard low range uk average estimates. 

Just try Change My Usage and add a little (it won’t change your estimated payments much — they are just estimates after all).

Userlevel 7
Badge +10

 @KGospodinova  (and @25 quid)

This is a bit of a mystery

I doubt it’s connected to usage I just tried both getting a quote and through movein using the same figures and it worked OK. (but it’s worth a try nonetheless)

(@25 quid movein doesn’t appear to care if there isn’t a pp account already, I tried a couple of addresses to check)

@KGospodinova Out of curiosity can you go back to the postcode and select a different house number or address (obviously don’t proceed if it works!).

The other thing to be aware of is using vpn’s or adblocking software (plugins or extensions in the browser)

(*It struck me as a possibility is that the previous occupants have only just moved out so maybe it’s locked the address temporarily and it will come right…?)


Over to you @KGospodinova… 😊 



I tried again and it still doesn’t work. In fact, the ‘choosing tariff’ step is even before I need to enter my post code. 


Any other ideas?


Thank you for your help. 



Userlevel 7
Badge +10


I don’t understand what you wrote. How can it quote without your postcode? rhetorical question because It can’t as it needs to know what area you’re quoting for.


What device are you using? Are you using the app or going online?

Have you tried from a different device? Are you using data or wifi?

Clear cache and cookies and re-boot?, try a different device?

Top tips from @woz there @KGospodinova. Let us know how you get on...

Hi again,

Where I get stuck is at the 'your quote' section in the move in part. No matter which option I select, nothing happens after I press the next button and so I can't proceed to the next stage. See a snapshot below. I can get a quote, but not when it's  part of the 'move in' section. 

I have tried using different devices, both the website and the mobile app. I've also cleared my cookies and restarted my devices, but nothing happens. I think it's something to do with my account... 

It might be useful if I could speak with someone.







Could you say what devices you are using? It might help PP (or another community bod) reproduce the fault.

Hi @KGospodinova and welcome to the Community!

Sorry to hear you’ve not been able to complete your move in.

I was going to suggest trying to clear your cache and your cookies, but can see you’ve already tried that! So I’ve flagged this up with our Tech guys to look into and get sorted for you :thumbsup:

In the meantime it may be worth checking if you’re running an adblocking or VPN/security software that could be preventing it from going through, just in case? 


Yes, I’ve tried that as well. I’ve deactivated both my adbloking and VPN, but nothing works. 

Hope it gets resolved soon. 

Thank you for your help!