HELP. I am joining Pure Planet, but cannot get to technical support as cannot log in.



Show first post

32 replies

Hi Marc, Thank you for that I did try everything you suggested but with no luck. I have had so much hassle over this, I'm worried what would happen come meter readings etc. I would rather go with someone I can call if I get into a pickle You have been very kind and helpful, but it's not the same as someone talking you through it on the phone looking at the account.
There is clearly something amiss with my account.
I don't want to start again as I came via MSE Energy club who offer a very good deal and I'm not sure I could get the same deal direct, also as I said before, I don't want the stress of not being able to contact PP. I am keen to have the switch cancelled as I am locked in to switching in the energy club so can't apply anywhere else.
​Thanks for your help
I am in the same predicament. I do not wish to have the app on my phone (it hasn't enough memory and stuff is failing on it all the time) and so I have tried to submit meter readings online. However, there is no way to submit the readings - the screen remains "blank" with just the title "Meter readings" - there are no boxes or anything to put the readings in.
stephenrand;39922:
Hi there
As this is your first post, welcome to the Pure Planet community!
I'm not clear what stage you have reached with joining Pure Planet. You are asked for your meter readings about 16 days after you initiate the switch. Have you got to that stage?
Post back, and I know people will be pleased to do what they can to help.
Stephen

Thank you for your reply.
Yes, I have been asked by PP for meter readings. I think I am logging in ok ie the "community" button on the left hand side works. (I log in by clicking on the "log in" button and "continue in browser" which tells me an email has been sent.)
However, the "send a meter reading" button on the left leads to a page with the heading "Meter Readings" but no box or anything else on the screen.
I have now missed the deadline given to me by PP so I suppose I will have to wait for their estimated bill... or will they be able to contact my previous supplier (Ovo) to find out the readings at switchover?
I am concerned I will not be able to contact PP as NOTHING from the drop down menu at the top right of the home screen works... all I get is a white box that appears at the top right but I can't click in it, and there is no other information.
The only thing that works is the "Community" button.... I don't know how I'm going to contact the Wattbots....
I joined today, also via MSE, and was nagged to complete the switch within less than 3 hours.
I got past the problems with logging in via a laptop by using the 'Home', 'Help' and 'Account' buttons - which only show up when one clicks on PP's own triple line icon on the right-hand side of the screen. That last option let me put in preferences (like not using a smartphone, or therefore apps) by putting in short instructions via their Priority Services registration system.
Those repeatedly described by other very new switchers on the first page of this thread. (It didn't seem helpful to quote them, yet again; everyone seemed to be facing much the same issues as me.)

I made the mistake of obeying the instruction to seek a quote when I followed the link in the first chasing e-mail and could then only find the Community as a way to ask anyone for help. After reading the various other complaints here, I tried clicking on the triple line icon and managed to sort things out from there. 'Help' got me to the Wattbot, which was useless about my not wanting the app but may have helped me to reach the Priority Services Register system. As I'd got stuck when the system was allegedly finishing my account, I also tried that. One way or another, I seem to have passed their obstacle course!
I am in exactly the same predicament, I have been trying to get in online to insert a meter reading, but NO WAY to log in. An awful circular argument with no solution and no one to ring. The worst service in the world.

Reply