Implemented

Change layout of polls so they come after the first post, not above it


Userlevel 7
Badge +11
  • Rocket Scientist
  • 11301 replies
Idea Status: Working On It


When you post a poll you have to scroll through the poll before you get to the post which introduces the poll. It matters because there may be explanations or instructions in the post (as there almost always are)
The post should come between the Poll title and the poll itself.

20 replies

Userlevel 7
Badge +5
Yep, I agree. Just made a mistake on your latest poll @woz cos I didn't read the post first for all the options.
Userlevel 7
Badge +11
🙂, never mind, but I bet you're happy with your birth month..
Scubaseahorse;35704:
Yep, I agree. Just made a mistake on your latest poll @woz cos I didn't read the post first for all the options.
Why not just have the reasoning for the poll then the poll and a link to another thread to discuss the poll?

A sort of vote only no posting thread.
Userlevel 7
Badge +1
woz;35689:
Idea Status: New When you post a poll you have to scroll through the poll before you get to the post which introduces the poll. It matters because there may be explanations or instructions in the post (as there almost always are) The post should come between the Poll title and the poll itself.

@woz: Perhaps this should be a poll :rolleyes:
​
Hey @woz @Scubaseahorse @X Driver @Oakbank
This is interesting because (you may be "too young" to remember 😂) but this is how polls used to be - they appeared just below the text of the first post. So, as you guys have pointed out, other Members could read the post for context, and then vote in the poll.
But it didn't work in Internet Explorer. Something to do with iframes. We made a change in Feb this year so that it works in all browsers... but it does mean, as you've pointed out, that someone can vote before they read the thread. And if they want to change the way they voted, it's too late!! :eek:
I'm going to see if it's been fixed by Microsoft so that we can put it back the way it was.
Userlevel 7
Badge +5
That would be great @Marc 👍
Hi all
Microsoft haven't fixed it yet, but apparently it's coming in their version of their Edge browser.
Here's a Microsoft forum thread about it (which is all Greek to me!).
The main thing is that when this is fixed, we'll be able to revert back to the old way of showing polls 🆙
Hello @woz @Scubaseahorse @Oakbank @X Driver
A quick update on this.
Our tech team say that there's a pretty big update coming to the 'Edge' browser on 15 January which may sort this polls issue for us.
Here's a post about the 15 Jan release. It does look like a big update. 🤓
Good morning @woz @Scubaseahorse @Oakbank
Some nice news for a Monday morning 😀
The Edge browser update has happened, and our polls work as they should again.
You can see in this poll from @Bev about Harry and Meghan that the poll comes after her post, not before it.
Marc;46706:
Good morning @woz @Scubaseahorse @Oakbank
Some nice news for a Monday morning 😀
The Edge browser update has happened, and our polls work as they should again.
You can see in this poll from @Bev about Harry and Meghan that the poll comes after her post, not before it.



Oh **** and **** and double-********.
Looks like while this might have fixed it for the Edge browser, it's now broken for Chrome.
I'm just going for a lie down and a little weep.

While I'm doing that, would anyone mind testing it out on Chrome for themselves? It might just be me. 😢

Sorry @woz @Bev @Scubaseahorse @Oakbank
Userlevel 7
Badge +10
LOL at your expletives 😂😂😂😂😂😂
Userlevel 7
Badge +9
Screaming in a pillow helps
Userlevel 7
Badge +11
I just posted a poll, seems OK in Chrome and Firefox but I can't see a poll in Edge!
Userlevel 7
Badge +5
You can't win them all @Marc
Userlevel 7
Badge +11
I think I got **** and **** but not sure about double ********, is it just **** twice or do I need to learn a new word?
Bev;46753:
LOL at your expletives 😂😂😂😂😂😂
Userlevel 7
Badge +10
I’ve no idea what any of them were, I just made my own up 😂😂😂😂😂
Userlevel 7
Badge +11
UPDATE, I reinstalled edge now OK...doh...
woz;46764:
I just posted a poll, seems OK in Chrome and Firefox but I can't see a poll in Edge!
....and breathe

Thanks for the support guys. I made it through the day without 'losing it'! 😄
I'm changing the polls back to the wrong way - where they appear before the first post - so they work for all browsers.
When it's fixed properly I will change it back.
Drum roll please... 🥁

In the new Community platform, polls appear underneath the post! 😁

Like so:

Great news! Polls are now back to how they should be, they come after your post.

Thanks - everyone - for your patience!

 

:grin:

Reply