Solved

Incompatible device and unable to set up account

  • 19 November 2017
  • 9 replies
  • 3527 views

I've tried to set up an account but failed at the first step, as when I attempt to download the app through Google Play it tells me it is not compatible with my device.

I have a galaxy Galaxy s4 mini GT-191951 running android 4.4.4

There are no contact numbers or e-mail addresses that I can find on your site that will allow me to contact anybody to solve this, and I find this very strange. It's as though you don't want any customers

I need to set this up today or I will revert to a higher tariff. Therefore if I receive no assistance via e-mail, then I'll switch to a different supplier.

Please don't contact me by my mobile phone as I am overseas and charges for received calls will be horrendous and I won't be too happy

thanks
icon

Best answer by Toby 20 November 2017, 10:02

Hi @gerrusg and welcome to the community!

Due to the fact that our app uses modern design and functionality, it will only work with operating systems (OS) and devices created after a certain time. For Android devices, they need to using OS version 5.0.0 or higher (iOS9 or higher for Apple devices).

Due to this, I don't think your current device and its OS will be able to run the Pure Planet app. Sorry about that!
View original

9 replies

Userlevel 5
Hi @gerrusg and welcome to the community!

Due to the fact that our app uses modern design and functionality, it will only work with operating systems (OS) and devices created after a certain time. For Android devices, they need to using OS version 5.0.0 or higher (iOS9 or higher for Apple devices).

Due to this, I don't think your current device and its OS will be able to run the Pure Planet app. Sorry about that!
So I was almost correct. You do want customers but only customers with phones purchased later than 2014.

If I understand this concept correctly, this is quite possibly the most ridiculous business scenario I've encountered in a very long time.

You're only offering your services to people with a smart phone, and only then if it's fairly new...

Good luck with you bottom line....
Userlevel 5
Hi @gerrrusg, thanks for your thoughts on this. I truly appreciate that the way Pure Planet works is perhaps not for everyone, but in order to create a 100% digital business, we have had to use the latest technology - Both in terms of our app software and what devices will run it effectively.

I shall be sure to pass on your thoughts on this though @gerrrusg. Its always appreciated!
Yup, I'm excluded too due to my 2014 device. I can't quite square the saving the planet line with requiring me to replace a working phone if I want to use your green energy. I get the online bit re costs but excluding a lot of older phone owners, pc, tablet and laptop users isn't very green. A bit like taking your stuff to the recycling depot in a gas guzzler and keeping the engine on in the queue.
Userlevel 5
Hi @zek and welcome. What device do you currently use? Can it be updated at all? I can offer help if possible on that.
Hi
I got Samsung s9 with android 8.0.0 and this app is incompatible with my device.
Userlevel 7
Badge +11
Just to say it will also run on a tablet or ipad (but the same constraints apply)
Also your phone will run Android 5 with a custom ROM if you're feeling brave.
If you were going down that route you wouldn't be doing it unless you had a fall-back plan, and certainly not while you're abroad, but then it's hardly PP's fault if you leave it to the last minute and just hope it works.
As I'm sure you know making apps backwards compatible has a huge cost, and sometimes isn't even possible, you have to draw the line somewhere, ask microsoft and apple.



gerrrusg;938:
I've tried to set up an account but failed at the first step, as when I attempt to download the app through Google Play it tells me it is not compatible with my device.

I have a galaxy Galaxy s4 mini GT-191951 running android 4.4.4

There are no contact numbers or e-mail addresses that I can find on your site that will allow me to contact anybody to solve this, and I find this very strange. It's as though you don't want any customers

I need to set this up today or I will revert to a higher tariff. Therefore if I receive no assistance via e-mail, then I'll switch to a different supplier.

Please don't contact me by my mobile phone as I am overseas and charges for received calls will be horrendous and I won't be too happy

thanks


- - - Updated - - -

It should be compatible, are you running original firmware?
Kamil K;16930:
Hi
I got Samsung s9 with android 8.0.0 and this app is incompatible with my device.
This app is some fake. I downloaded Android 5.1 on a PC and it still does not work.

- - - Updated - - -

I'm going to look for another energy supplier

- - - Updated - - -

I'm going to look for another energy supplier
Userlevel 7
Badge +11
The app isn't guaranteed to run under emulation.
If you are running a VPN it can cause problems, but as far as compatibility goes no one else (as far as I know) has found an issue of being unable to actually install on Android 5 and above. They may well have found functionality issues after install but the app has been compatible.
My guess is perhaps there's something about your phone setup (language/region etc ) which makes it think the app isn't compatible.
So I'm not accused of being defensive I'll add that I think there are many things about PP that need fixing.

Good luck with whichever supplier.
Kamil K;16948:
This app is some fake. I downloaded Android 5.1 on a PC and it still does not work.

- - - Updated - - -

I'm going to look for another energy supplier

- - - Updated - - -

I'm going to look for another energy supplier

Reply