Solved

Why do I get no response to my emails to Pure Planet ?

  • 24 November 2020
  • 14 replies
  • 179 views

Userlevel 1

Why do I not get any response to my emails to Pure Planet ? 

 

 

icon

Best answer by Ian1951 30 November 2020, 13:14

Hi All,

It looks like I had not been receiving my emails for a few days due, I suspect to my lack of understanding about how to use a laptop. I now see that I DID get a response to my replies to PP,  but not until Wednesday, 25 November 2020, when PP sent 2 emails to me.  The first email contained a monthly statement to replace the previous statement and it DID note my correct customer readings.

I will now wait and see what happens on 16 December 2020, when I will be due to send in my next monthly readings.

Many thanks to everyone in the Community, who tried to help me.

Ian.

View original

14 replies

Userlevel 7
Badge +9

HI Ian,

Welcome to the community.

This is a digital platform and the main communication tool is wattBot. The bot may be just that when asking general stuff and getting bot (pre programmed answers) responses, but if you first type “Message the Team” via wattBot then your questions will get a human response from one of PP’s account handlers in 2/3 days.

As its fast approaching the weekend I would proceed to do that.

You can always resource your fellow members as this community was set up to do with any questions? Plus the FaQ’s has lots of stuff….

And of course you can always send a DM to one of 2 PP community managers, but they have no access to our accounts.

 As I understand it the email facility for members to use is only subject to certain scenarios and I have never had to use it. So head to wattBot and prefix as advised...plus you will receive a text prompt from PP to look back in bot space for their reply if your busy.

All the best

Userlevel 1

Pure Planet sent emails to me which I replied to, but I got no response.

Userlevel 7
Badge +9

Hi @Ian1951 

I'm guessing you might have been born the same year as me!

Your question is a fair one - help@purepla.net is quoted as a way to contact Pure Planet, but with no indication as to how long it might take to get a reply. In normal circumstances I would expect about 3 days, but I've no idea whether that's what happens. And we do know that PP have been struggling to respond as quickly as normal because of lockdown.

As my good friend @Strutt G says, Wattbot is seen as the quickest way of contacting the team, and often the quickest way of getting help is by asking the community.

Out of interest, how long have you been waiting for a reply?

Stephen

Userlevel 1

Hello Stephen,  I replied to Pure Planet’s last email on 18 November 2020, with no response, as yet.

Userlevel 7
Badge +10

@Ian1951 

hi Ian

use wattbot as suggested, it’s designed for support also have a read of the below, which was going to be my reply here but now isn’t...

 

https://community.purepla.net/testing-and-feedback-23/email-vs-wattbot-rumble-in-the-jungle-11697

Userlevel 7
Badge +9

Hello Stephen,  I replied to Pure Planet’s last email on 18 November 2020, with no response, as yet.

Thanks for the info. So today is the fourth working day. I think I would have hoped for an answer by today, probably got frustrated tomorrow! That's just me…

Stephen

Userlevel 1

Hello Stephen,  I switched supplier by using Money Saving Expert on my laptop.  I did not know that I had to use an “app” ( whatever that is ) on a phone. I don’t know what an “app” is and  I don’t know how to use one.  With my previous supplier ( Bulb ), I typed my readings into my laptop, with no problem.  I assumed ( wrongly it seems ) that it would be the same with Pure Planet.

Userlevel 7
Badge +9

Hi @Ian1951 

You don't need to have the app. You can do everything you need to do at www.purepla.net

So you login there (and stay logged in for ever, makes life easier) and enter your meter readings each month.

You haven't said what answer you're hoping for to your email. If it's a question about how things work, and not specific to your account, post it here and you'll have an answer in no time!

Stephen

Userlevel 7
Badge +9

Hi Ian,

You can log in with your laptop. PP started out as an APP only based company when I joined up and now I can access my account by the APP and the online account.

So with your laptop proceed to https://purepla.net then click on the 3 lines top right of your screen. Look at the drop down menu, login is down the list so click on that - enter your email.

PP will send you an email in few minutes...then click on that link which logs you in.

Have a great day and hope you get sorted soon

Userlevel 1

Hello Stephen and Strutt,  Thanks for your responses.  I received an email from PP on 13 November 2020, which asked me to provide my readings.  I tried to do this on 15 November 2020, however a message on the screen said “ This browser is unsupported. “, although the browser on my laptop is Microsoft Edge.  So I replied to PP’s email explaining what had happened and included my correct readings.  However on the statement sent to me by email, a few days later, I saw that PP had used estimated readings and had ignored the correct readings, which I provided.  I’ve still had no response from PP.

Userlevel 7
Badge +10

Hello Stephen and Strutt,  Thanks for your responses.  I received an email from PP on 13 November 2020, which asked me to provide my readings.  I tried to do this on 15 November 2020, however a message on the screen said “ This browser is unsupported. “, although the browser on my laptop is Microsoft Edge.  So I replied to PP’s email explaining what had happened and included my correct readings.  However on the statement sent to me by email, a few days later, I saw that PP had used estimated readings and had ignored the correct readings, which I provided.  I’ve still had no response from PP.

@Ian1951 A couple of suggestions, are you running an adblocker or vpn, if so that might be the reason?

(I just tried edge it seems OK but I didn’t try every option)

Did you try firefox or chrome?

Userlevel 7
Badge +9

Hello Stephen and Strutt,  Thanks for your responses.  So I replied to PP’s email explaining what had happened and included my correct readings.  However on the statement sent to me by email, a few days later, I saw that PP had used estimated readings and had ignored the correct readings, which I provided.  I’ve still had no response from PP.

Hi @Ian1951 

My guess is that your readings have not been ignored, but rather that either your readings can't be entered this way, or whoever received your email hadn't got round to it in time.

My advice would be just to wait until you get your next prompt for a meter reading and enter them then. It won't affect what you pay, and I doubt your account will get out by very much in four weeks.

That doesn't solve the problem with the browser. There's been very few posts about a problem like this. Try what @woz has suggested, let us know how you get on - if you are successful then you'll be able to enter your meter readings! I think you have been very unlucky - sometimes you get a warning like this and everything's fine next time you try.

Stephen

Userlevel 1

Hi All,

It looks like I had not been receiving my emails for a few days due, I suspect to my lack of understanding about how to use a laptop. I now see that I DID get a response to my replies to PP,  but not until Wednesday, 25 November 2020, when PP sent 2 emails to me.  The first email contained a monthly statement to replace the previous statement and it DID note my correct customer readings.

I will now wait and see what happens on 16 December 2020, when I will be due to send in my next monthly readings.

Many thanks to everyone in the Community, who tried to help me.

Ian.

Great that it sounds like you’re back on track Ian! Thanks for posting your update.

Reply