Solved

Meter reading weirdness, and I just gave an incorrect reading

  • 27 August 2019
  • 6 replies
  • 345 views

So, today I discovered that my electricity meter has a blank for one of the final digits. I never noticed before. I’ve got several years’ photos of the meter by way of old readings and it’s evident on those.

As a consequence I’ve just given PP an incorrect reading, a 4-digit number rather than a 5-digit number. I assume I can rectify this when support is open tomorrow.

But the real problem is that I’ve analysed my account, and the most recent “actual” read they have is higher than the current read! This reading must have been taken by a meter-reader since I don’t have a photo for it and I vaguely remember the meter being read.

So it seems the read was false. It’s no big deal and in fact means I probably paid for more electricity when prices were lower but I’m somewhat surprised that it happened at all!

Is this a common occurrence?
icon

Best answer by woz 28 August 2019, 15:53

hi redpola
It's obviously broken, looks like it's stuck, you need to request a meter replacement, you can do that in wattbot type message the team and ask.
When you said it was lower you didn't give all the facts, it looks like it's stuck around the 9699- - 97000 mark, my guess is it will never move far from that if at all and the other reading is incidental, presumably the 88408 was a long time ago (more than a year?)
redpola;36353:
My meter was read on 31/01/19 and read as 97000. Today it reads 9699(blank). I do not have a solar install and am only a consumer.
View original

6 replies

Userlevel 7
Badge +10
hi redpola
can you post a photo? (obliterate the serial if you can).
If it's the least significant digit I can't see it would make much difference but either way it will be obvious where the error if any lies if assumed to be a zero, but if they've treated the remaining 4 digits as 1000's 100's, 10's and units that as they say is a whole new ball game...
Here is an example:
What you see 5678(0) then 5713(0) in one month (0) assumed to be last digit in units
real difference =350 (350 assumed to be a typical month give or take)
or 05678 +350 = 06028 if those were the readings, 5678(0) and 6028(0)=3500, I think you'd know if that was the case and you were charged for 3500 kWh in a month!
That's why I can't make sense of this yet.
Without knowing the meter reader's numbers compared to yours there is't enough info to guess what's happened, are you sure you've been reading it correctly?
Go to help, wattbot, type message the team if you want to contact PP, in the meanwhile I doubt it's a bad as you think unless your monthly payment for electric is over £500
redpola;36293:
So, today I discovered that my electricity meter has a blank for one of the final digits. I never noticed before. I’ve got several years’ photos of the meter by way of old readings and it’s evident on those.

As a consequence I’ve just given PP an incorrect reading, a 4-digit number rather than a 5-digit number. I assume I can rectify this when support is open tomorrow.

But the real problem is that I’ve analysed my account, and the most recent “actual” read they have is higher than the current read! This reading must have been taken by a meter-reader since I don’t have a photo for it and I vaguely remember the meter being read.

So it seems the read was false. It’s no big deal and in fact means I probably paid for more electricity when prices were lower but I’m somewhat surprised that it happened at all!

Is this a common occurrence?
You don’t seem to have addressed that my last actual reading (97000) is higher than my current reading (on the right).

Userlevel 7
Badge +10
I didn't "address" it because I didn't have enough info, hence asking for a photo.
Your post is confusing my last actual reading (97000) is higher than my current reading (on the right). , do you mean the latest reading is on the right (9699-) or that the latest reading is on the left?
If the lower reading is later than the higher reading and/or it's sticking you need a new meter, either the leftmost 8 has flipped to a 9 or vice versa, or its going backwards?
You don't have a solar install by chance?
redpola;36328:
You don’t seem to have addressed that my last actual reading (97000) is higher than my current reading (on the right).

2671
My meter was read on 31/01/19 and read as 97000. Today it reads 9699(blank). I do not have a solar install and am only a consumer.
Userlevel 7
Badge +10
hi redpola
It's obviously broken, looks like it's stuck, you need to request a meter replacement, you can do that in wattbot type message the team and ask.
When you said it was lower you didn't give all the facts, it looks like it's stuck around the 9699- - 97000 mark, my guess is it will never move far from that if at all and the other reading is incidental, presumably the 88408 was a long time ago (more than a year?)
redpola;36353:
My meter was read on 31/01/19 and read as 97000. Today it reads 9699(blank). I do not have a solar install and am only a consumer.
redpola;36353:
My meter was read on 31/01/19 and read as 97000. Today it reads 9699(blank). I do not have a solar install and am only a consumer.


Hi redpola,

Have you got any photos dated between 31/1 and 28/8 of the readings you were submitting?
Did the reading of 97000 fit in with your regular unit consumption at 31/1?

My first thought is that the gearing on the dials has seized.

Reply