Question

meter problem

  • 7 January 2021
  • 6 replies
  • 61 views

Hello, I have a difficult issue I hope someone can help with. Both my gas and electricity meters are not working , though there is still supply to the property. Pure Planet have informed me that the meters are due to be upgraded sometime before the end of March. However, I am selling my house and the sale is due to go through in the next week or two. I there am unable to provide last meter readings to the new owners and they will not be able to give readings when they take ownership. WotBot has not responded to my request for help. I’m desperate! Can anyone advise please? 🙏🏻


6 replies

Hi @KateManley 

Welcome to the community.

May I enquire, what do you mean by ‘not working’ and did Pure Planet explain what the ‘upgrade’ is?

I have a theory, but really need more information on what your meters are, presumably SMETS1 ‘Smart Meters’?

Kindest Regards

Gwyndy

Userlevel 7
Badge +10

Hello, I have a difficult issue I hope someone can help with. Both my gas and electricity meters are not working , though there is still supply to the property. Pure Planet have informed me that the meters are due to be upgraded sometime before the end of March. However, I am selling my house and the sale is due to go through in the next week or two. I there am unable to provide last meter readings to the new owners and they will not be able to give readings when they take ownership. WotBot has not responded to my request for help. I’m desperate! Can anyone advise please? 🙏🏻

@KateManley A stupid question I know, but if the meters are smart  have you woken the meters displays by pressing a button, or are they older meters both of which have failed at the same time(hard to believe if so)

Hey @KateManley 

I’ve just replied to your DM, too :slight_smile:

It sounds like you may have first-generation smart meters (also known as SMETS1) - you’re able to get your readings from these by pressing a button to wake the screen up. 

We have a guide on what to do in our FAQs which may help? 

Thank you for your responses.

 

@Nataly and @woz yes, I have tried pressing the buttons to activate the meters but nothing comes on.  It does seem very odd that they have both failed at the same time.

 

Yes they are SMETS1 meters.  I’d welcome any ideas or tips on things I could try or possible explanations.

 

I really need to speak to someone at PP.  Is there any way to make this happen?!

Hmm that is really strange! 

The best way to get in touch with our Member Services team is by logging in to your PP app, or at purepla.net, and selecting ‘get help and support’ > ‘ask a question’. I’d type along the lines of ‘meter is broken’. Once your convo’s passed through to the team, they’ll be able to look into this and let you know what to do. 

Generally if you aren’t able to provide readings, we’ll produce industry-estimated readings instead - which are often pretty accurate! So don’t worry, we’d be able to use estimated readings instead around your home move :slight_smile:

Userlevel 7
Badge +10

Thank you for your responses.

 

@Nataly and @woz yes, I have tried pressing the buttons to activate the meters but nothing comes on.  It does seem very odd that they have both failed at the same time.

 

Yes they are SMETS1 meters.  I’d welcome any ideas or tips on things I could try or possible explanations.

 

I really need to speak to someone at PP.  Is there any way to make this happen?!

@KateManley

try holding the button down  for a couple of seconds?

Which button are you pressing?

Reply