How to submit meter readings in the app


  • Community Manager
  • 6128 replies
Having trouble submitting meter readings in the app?

Make sure you have the latest version of the app. To be certain you should uninstall it and reinstall it from the App Store or Google Play

Then follow these simple steps:

1. Open your Pure Planet app.

2. When it's time for your reading, you'll see a 'Send a meter reading' moon right on your homepage.



3. If you want to send us a meter reading at other times, go to Menu > Send a meter reading

4. All you need to do now is type the number(s) on your meter and press 'Next'.

If you have any questions check the guide just below the meter submission box(es).



5. You'll get a chance to review the numbers before you finally submit. It's always handy to check.

6. You'll then see a confirmation that we have received them, with a big green tick

Finally, it's worth remembering that you can only send meter readings once every 24 hours. If you try to re-send them sooner, the ‘send’ button will be greyed out and we’ll let you know that we don’t need another reading just yet!

Please send us regular meter readings once a month. It helps to keep your energy use and payments on track.

110 replies

Update:

It is believed that some members experiencing an issue when following an email prompt from Pure Planet to submit meter readings and being caught up in a login 'loop' is caused by having a 'VPN' installed on their phones.
VPNs are 'virtual private networks' which some apps will install on phones - for example to have better privacy when using public wifi networks.
Having a VPN may stop our verification email from working. We are investigating further.
You can see if your iPhone has a VPN installed by checking in Settings->General-VPN where it can be disabled
Can’t log on keeps directing me to authenticate email then says token error . Trying to send metre reading . Does pureplanet have customer services number to speak to a human ?
Hi @Iancluc thanks for posting
I've moved your post to this existing thread - as it's the same topic and duplication is hard for members to follow.
Can you please make sure that you've got the latest version of the app installed and then follow the steps as above?
We have a bug affecting some members' apps with regard to sending meter readings and the above steps are doing the trick
I still have had no success it getting an accurate figure for my gas usage - electric seems to ya e worked. I’m becoming very frustrated now as I have no idea what the cost of my gas is. I’ve done everything suggested and you were meant to be in touch - you haven’t. Please can someone sort this out - I’ll move supplier if not. Can’t be hit with a massive bill.
I submitted readings around 2 weeks ago but in the app it still shows estimated usage. I had good connectivity and no vpn
I am really struggling to send my meter readings from my phone. Can I send them via e-mail from my desktop or computer?

Jill Thomas
Joseph S;4347:
I still have had no success it getting an accurate figure for my gas usage - electric seems to ya e worked. I’m becoming very frustrated now as I have no idea what the cost of my gas is. I’ve done everything suggested and you were meant to be in touch - you haven’t. Please can someone sort this out - I’ll move supplier if not. Can’t be hit with a massive bill.


Hi @Joseph S
Let's get this sorted. I've checked this with the team.
An email was sent to you asking for photos of your gas meter. Did you receive that email? If not please check your spam/junk folder.
jillyct1;4361:
I am really struggling to send my meter readings from my phone. Can I send them via e-mail from my desktop or computer?

Jill Thomas


Hi @jillyct1
Thanks for posting in the community
What's happening when you try to submit them?
Martynh;4355:
I submitted readings around 2 weeks ago but in the app it still shows estimated usage. I had good connectivity and no vpn


Hi @Martynh
When was your switch date? A month from then you should have received your first statement (by email) and started seeing your energy tracker (in the app).
I switched in Dec. First month shows fine, it's the 2nd month that hasn't shown yet
That's great @Martynh thanks for the reply. I'm going to DM you as it will have account info
Hi, I'm trying to submit my meter reading, it says that the reading seems low, that I should check it and the submit button isn't live so I can't send. I have checked the meter readings twice. Am happy to send a photo but there's no option to do that. The help buttons just freezes the app and the little bott thing isn't working. I've updated the app today and followed a link to submit readings from an email received yesterday. What can I do now, nothing is working? Thanks.
Hi @Mrs B
Instead of following the email link, can you try just going to Menu > My account > Send a meter reading
Is that any better?
I am also struggling to even get to the page for submitting my meter readings. I have the latest version of the app (7.0.13), but when I tap on My Account it just says Trying to connect but times out. Not impressed as a new customer. You should at least have an alternative e.g. email. I hope someone can resolve this ASAP and get back to me.
Renate;4419:
I am also struggling to even get to the page for submitting my meter readings. I have the latest version of the app (7.0.13), but when I tap on My Account it just says Trying to connect but times out. Not impressed as a new customer. You should at least have an alternative e.g. email. I hope someone can resolve this ASAP and get back to me.


Hi @Renate
Sorry to hear this. Can you please tell me what phone you have, and which version of the operating system it is running? It will help when I report this to the app team.
(I'm also assuming you've got decent wifi/data connection too)
Just tried to respond to this via email on my computer but it failed to deliver.

Phone: iPhone SE
iOS: 11.2.6
Home WiFi working fine, upload ~5Mb, download ~90Mb
Thanks @Renate that's brilliant.
Nothing wrong with your phone.
The guys are looking at an issue with a third party's servers and our app.
In the meantime please keep trying. I do appreciate that's very far from ideal, but the issue is intermittent (and appears to be quite random in terms of who gets hit with it) so it will work after a few attempts.
They have one other suggestion re your specific phone - checking that you have enough storage. This could affect the app if your handset is full
I will keep trying. Only had the phone a month or so and have used ~20% of available storage so unlikely to be a fault with the phone.
Hi @Renate
The other thing that's worked for others is to delete the app and then reinstalling it. Not sure - have you already tried that?
Have tried that way too, same problem. I'm also a new customer, joined in December, not very impressed with this. If you have app problems you need a back up system so we can email the readings through, I don't have time to mess about with this.
Hi @Mrs B
What kind of phone have you got? And what version of the operating system does it have?
Did you also update to the latest version of the app - that's 7.0.13?
Lots of questions, I know, but it will help get this resolved for you
Thanks for responding, I'm using an iPad, iOS 9.3.5. App version 7.0.13. I think the problem is that it doesn't like my low meter readings and wants me to check. I can get to the final page but the submit button isn't live.
Thanks @Mrs B
iOS 9.3.5 is less than two years old so it should be ok. I will double-check this with the app team
I have tried many times since yesterday, still not connecting. There needs to be an alternative offered, rather than just via your phone app. Not impressed.

- - - Updated - - -

Okay, I’ve managed to uninstall and reinstall the app and it now allowed submission of readings

- - - Updated - - -

So I’ve managed to uninstall and reinstall the app again, and was successful in submitting readings. As the other person said, I got a message saying the readings were low, but it still accepted them.
Hi @Renate
That's great - glad it's now working. Apologies for the hassle.

Reply