Can't access my account/give meter reading


Could you help me please. Had an email today asking me to submit my meter readings (in the middle of switching to Pure Planet), but my app seems to have reverted back to how it was before I started switching with the 'get a quote' home screen and no option to access my account or give a meter reading. How do I rectify this?

24 replies

Userlevel 7
Badge +9
Hi bobinogs.
My first question is have you signed into the app properly. And have you got the latest version of the app ?
You could delete and reinstall app just to make sure.
Jon1;9736:
Hi bobinogs.
My first question is have you signed into the app properly. And have you got the latest version of the app ?
You could delete and reinstall app just to make sure.


Hi Jon.. I've uninstalled and reinstalled the app. Signed in and clicked on link in email to verify who I am, but still goes straight to the 'get a quote' home screen.
Userlevel 7
Badge +9
Hi again.
Have read somewhere someone else who had the same issue. I cant remember when it was but have a feeling there was a typo on the acct which prevents your email,phone and acct syncing up. Once marc sees this post he should be able to help further.
Hope its sorted soon.
Hi @Bobinogs75
If you're seeing the get a quote screen it means you're not logged in.
It could be a login 'loop'.
This can happen when going to email from the app to click on the security check to verify your account, your phone will not necessarily show you the most recent email from us - you're taken straight to an older email, not the inbox 'list' view of all emails.

So to be sure, after entering your email address into the app to login, instead of following the link from the app to your email, simply press your home button, then open your email app, be 100% sure you open the most recent email from Pure Planet, and then tap on 'finish your security check'.

If that doesn't work, it may be technical. What phone/OS are you using?

Bobinogs75;9737:
Hi Jon.. I've uninstalled and reinstalled the app. Signed in and clicked on link in email to verify who I am, but still goes straight to the 'get a quote' home screen.
Marc;9748:
Hi @Bobinogs75
If you're seeing the get a quote screen it means you're not logged in.
It could be a login 'loop'.
This can happen when going to email from the app to click on the security check to verify your account, your phone will not necessarily show you the most recent email from us - you're taken straight to an older email, not the inbox 'list' view of all emails.

So to be sure, after entering your email address into the app to login, instead of following the link from the app to your email, simply press your home button, then open your email app, be 100% sure you open the most recent email from Pure Planet, and then tap on 'finish your security check'.

If that doesn't work, it may be technical. What phone/OS are you using?


Hi Marc

Just tried again, deleted all old emails first and pressed on link sent by going into my email app via the home button instead of through the app and it's still the same.
I'm using a Samsung S9.
Also when I attempt to log in, it says 'account verified, logging you in' but it always goes to the quote homepage.
Thanks @Bobinogs75 our tech team are looking into this 🆙
Hi again @Bobinogs75
You're now able to login OK?
Marc;9776:
Hi again @Bobinogs75
You're now able to login OK?


Logged in and meter readings with photos sent 😊
Userlevel 7
Badge +9
Woohoo go bobinogs.
Welcome aboard..
Having the same problem, tried all the suggestions.

- - - Updated - - -

How!! I still haven't managed to get in despite following the same procedures!
Userlevel 7
Badge +9
Hi sail can you please post what device and operating system it is running
I have been trying most of yesterday and today to try to open Pure Planet from my mobile phone but the PP logo comes up but just hangs there. My question is am I now signed up to Pure Planet and, if so, I have changed my mind about switching and no longer wish to make the switch. I have found the whole switching experience an absolute disaster. I have now uninstalled the Pure Planet app from my phone and reiterate that I wish to CANCEL the switch if, indeed, the procedure has already started. Could you please confirm that no further action will be taken on your part.
Userlevel 7
Badge +9
Hi Loz
What emails have you had regarding the switch?
If you have started the switch then you need the app to cancel the switch.
Im guessing you have not been able to download and run the app,if this is the case then its usually your device is not compatible with the app.you can only switch to PP with the app so if you never got it working you proberly have not started the switch.
Hi @loz
Have you received an email welcoming you to Pure Planet, with a welcome pack attached which states your supply start date?
Hi @SalL
Thanks for posting.
I'm a bit confused by the update to your post, though.
Are you able to login OK or is there still an issue? If so what kind of phone are you using, and running which version of the OS?

SalL;9909:
Having the same problem, tried all the suggestions.

- - - Updated - - -

How!! I still haven't managed to get in despite following the same procedures!
Hi Marc - no I received nothing and have now uninstalled the app but thank you for getting back to me.
Hi @loz
No worries, you're welcome! :)
OK that means you haven't switched and there's nothing to cancel 🆙
Marc, I have exactly the same issue, tried all solutions offered above
Hi @sem101
Welcome to the community
What are you trying to do?
I have exactly the same issue as bibinogs. I need to enter my first meter reading but my app thinks I am a new user with no account.
Hi @sem101
And you're definitely logged into the app?
(Basic question I know but worth eliminating it 🆙)
Look at homepage - it has your first name under the planet if you're logged in
Marc, no, it thinks I'm a new user without account, but logging in and out under my e-mail or re-installing the app makes no difference.
Good morning @sem101
OK. Can you let me know what make/model of phone you've got, and also what version of the OS it's running.
Either post it here or DM me. I'll ask our tech team to investigate

Reply